# [Algorithm/JS] 백준 10869번 사칙연산

🔗 문제 바로가기 (opens new window)

# Question

두 자연수 A와 B가 주어진다. 이때, A+B, A-B, A*B, A/B(몫), A%B(나머지)를 출력하는 프로그램을 작성하시오.

# Input

두 자연수 A와 B가 주어진다. (1 ≤ A, B ≤ 10,000)

# Output

첫째 줄에 A+B, 둘째 줄에 A-B, 셋째 줄에 A*B, 넷째 줄에 A/B, 다섯째 줄에 A%B를 출력한다.

# Example Input

7 3
1

# Example Output

10
4
21
2
1
1
2
3
4
5

# Solution

const fs = require('fs');
const input = fs.readFileSync('dev/stdin').toString().split(' ').map(Number);
let [a, b] = input;
console.log(a + b);
console.log(a - b);
console.log(a * b);
console.log(parseInt(a / b));
console.log(a % b);
1
2
3
4
5
6
7
8

나누기 연산의 경우 나누어 떨어지지 않는 수일때 2.33333333... 과 같이 소수점을 날려 정수만 출력할 수 있도록 parseInt 함수를 사용했다.

Last Updated: 2022. 6. 5. 오후 3:42:39