# [Algorithm/JS] ๋ฐฑ์ค 10998๋ฒ AxB
๐ ๋ฌธ์ ๋ฐ๋ก๊ฐ๊ธฐ (opens new window)
# Question
๋ ์ ์ A์ B๋ฅผ ์ ๋ ฅ๋ฐ์ ๋ค์, AxB๋ฅผ ์ถ๋ ฅํ๋ ํ๋ก๊ทธ๋จ์ ์์ฑํ์์ค.
# Input
์ฒซ์งธ ์ค A์ B๊ฐ ์ฃผ์ด์ง๋ค (0 < A, B < 10)
# Output
์ฒซ์งธ ์ค์ AxB๋ฅผ ์ถ๋ ฅํ๋ค.
# Example Input
3 4
1
# Example Output
12
1
# Solution 1
๋ฐฐ์ด ๋ฉ์๋ reduce ์ฌ์ฉ
const fs = require('fs');
const input = fs.readFileSync('/dev/stdin').toString().split('').map(Number);
let answer = input.reduce((a, b) => {
return a * b;
});
console.log(answer);
1
2
3
4
5
6
7
8
2
3
4
5
6
7
8
# Solution 2
๊ตฌ์กฐ๋ถํด ํ ๋น
const fs = require('fs');
const input = fs.readFileSync('dev/stdin').toString().split(' ').map(Number);
const [a, b] = input;
console.log(a * b);
1
2
3
4
2
3
4
โ 1001๋ฒ A-B 1008๋ฒ A/B โ